Page 2 of 2

Re: Compatible / not compatible scripts and mods

Posted: Thu Feb 11, 2010 4:08 am
by X3 - Saturana
I've tried the old (not lite) manager (had the problem of not beeing compatible with newer spk's
I've also tried the lite beta version - had the problem with ReadText
I can try the normal lite version and see if that helps. (Nope still some readtext errors, cant figure out what they are though)

But anyone else had any problems with ST/UT orders missing (or is this intended?)

EDIT: Fixed the ST/UT with a fresh install. Still have some wares that gives me readtext, but with some (actually) alot of post it notes its playable just a minor inconvinience.

REEDIT: the "UT for most ships" now also works

Love the mod great work guys, keep up on the good work :D

Re: Compatible / not compatible scripts and mods

Posted: Tue Feb 16, 2010 7:33 am
by Bali
Hi all.

I wanted to inform you that the latest version of Serial Kicked's Pirate Guild 3 is not fully compatible with DDTC 1.0. Everything starts up nice, but after activating PG in pirate base and also in bases belonging to some corporations, an item labeled as "ZZ_EMP_MOD_USE_ONLY10_1" shows up.  I checked carefully, and I am 100% sure it's because of activating PG.  I have many other mods and everything else works fine with DDTC.
Here is a list of my mods (names of file):

Libraries:
Befehlsbibliothek_X3TC_V3406
JSON parser library-V1.0-20.10.2009

Mods and scripts:
Community Plugin Configuration-V1.41-17.01.2010
emp.1.4
EMP-X
Dockwarenmanager_X3TC_V3104
EquipmentResearchandDevelopment-V1.00-03.06.2009
Handelsvertretung_X3TC_V3214
NPCBailingAddon-V1.6.4-11.09.2009
Prospektor_X3TC_V3203
SalvageClaimSoftware-V1.21-20.01.2010
SalvageInsuranceContract-V1.00-28.11.2009
SCS3.28.9tc
Security Services r2
Shipkillednotifications-V1.0.3-16.11.2008
Shiploot v1.04
RRF.1.7
UniversalBestBuysSells_251
WareManager-V1.00-31.05.2009
Warenlogistiksoftware_X3TC_V3204
Winghotkeys-V1.20-09.06.2009
achievement_guild_beta
Custom_Wing_Manager_v2
Marine_Training_Manager_v2
tc.bountyboost.1.1
turret-on-off-tc
mars-tc

Re: Compatible / not compatible scripts and mods

Posted: Tue Feb 16, 2010 2:05 pm
by Vayde
Hi Bali. If you read carefully through your own post you will see the answer to your problem, and it's not Pirate guild btw.

You said "ZZ_EMP_MOD_USE_ONLY10_1" shows up.

In your list of mods and scripts you have.
Community Plugin Configuration-V1.41-17.01.2010
emp.1.4
EMP-X
Dockwarenmanager_X3TC_V3104
EquipmentResearchandDevelopment-V1.00-03.06.2009

I've highlighted the problem for you.

Re: Compatible / not compatible scripts and mods

Posted: Thu Mar 04, 2010 1:57 pm
by khang42
Pirate Guild 3 does not appear to be compatible. Using only DDTC and Pirate Guild 3, none of the new ships show up. Missions are still there, but they produce no reward and no blueprints to buy ships. Cannot even cheat in the ships.

I am using the Steam version of x3:tc, updated to 2.5.

Re: Compatible / not compatible scripts and mods

Posted: Sun May 23, 2010 2:19 pm
by Russian Ranger
Hmm, I'm having the same problem as you on two different computers, but the same mods/scripts. I disabled PG3 and no dice. Unlike you though, I have many more mods/scripts.

Re: Compatible / not compatible scripts and mods

Posted: Sun May 23, 2010 3:05 pm
by Deadly
I've never used the Pirate Guild, but if you are not seeing DDTC ships then I can only assume that it modifies the TShips file.

Re: Compatible / not compatible scripts and mods

Posted: Sun May 23, 2010 4:22 pm
by draffutt
pirate guild doesn't have a tship. its a problem with plugin manager and how it is used.

Re: Compatible / not compatible scripts and mods

Posted: Sun May 23, 2010 4:43 pm
by Yacek
I'm using DDTC PG3 and a very long time and I have no problems. PG3 DDTC uses the ship. PG3 installed but not using PM (Lite). I installed manually copy the script files.

Re: Compatible / not compatible scripts and mods

Posted: Sun May 23, 2010 8:39 pm
by Russian Ranger
Yeah, I figured this out in a separate topic as well. Thank you for the replies. Now time to rework my TC folder!\

EDIT: One thing you may want to add, be sure not to add ANY Tships doc to the types folder prior to the launch of DDTC. The MARS adds a Tships text file which WILL hinder the stock of new ships.

Re: Compatible / not compatible scripts and mods

Posted: Fri Jan 20, 2012 6:33 am
by AgentExeider
Hey Deadly

long time no see,

starting with 1.3, I have been noticing a problem with some of Cycrow's scripts that i like to use and for some reason they wont show up, in addition to some weird wares.

ps. i am using the most recent version of the plugin manaager, version 1.41

My installed script and script libs are:

Installed Scripts 4/4:
Advanced Jumpdrive
Advanced Jumpdrive - Overrides
Cheat Collection Package
Slipstream Drive

Script Libraries 3/3:
Community Plugin Configuration
Hotkey Manager
Ware Manager


ps. Advanced Jumpdrive is dependant on the Ware Manager


the weird wares are:

SS_WARE_SW_NEW1
SS_WARE_SW_NEW10
SS_WARE_SW_NEW11
SS_WARE_SW_NEW12
SS_WARE_SW_NEW15
SS_WARE_SW_NEW16
SS_WARE_SW_NEW17
SS_WARE_SW_NEW19
SS_WARE_SW_NEW20
SS_WARE_SW_NEW4
SS_WARE_SW_NEW5
SS_WARE_SW_NEW6
SS_WARE_SW_NEW7
SS_WARE_SW_NEW9
SS_WARE_SW_X3TC_2
SS_WARE_SW_X3TC_3
SS_WARE_SW_X3TC_4
SS_WARE_SW_X3TC_5
SS_WARE_SW_X3TC_6


Now I know the advanced jumpdrive is 3 items, and the slipstream drive is just 1, so where the rest of these wares are coming from, i have no idea.

I'm still experimenting, but I could use some help.


Re: Compatible / not compatible scripts and mods

Posted: Sat Jan 21, 2012 3:36 pm
by Vayde
Hi AgentExider welcome to the world or the real (sorry ghastly matrix dialogue)

Your problems all stem from using cycrows plugin manager I'm afraid. DDTC all versions, and the plugin manager are not compatible The plugin manager writes it's own Tfiles when you run it, they can be found in the root directory of your TC installation. This completely trashes DDTC which is why it's number one on the none compatible list. As a work around I use the spk explorer and just extract the files I need then manually install them.

Sorry I could not fix the issue :(